ANNA
       Free Cat
       Кредо Группы 2А
  2A Представляет:
     Наши статьи
     Картины Анны
     Рассылки
     Проекты
     Книги
     Мы поддерживаем

   Написать письмо
   Послать Открытку
   Завалиться в Форум
   Потрепаться в ЧАТе
   Закрытая Гостевая
   На Главную
 

Работаем в новом WebMoney Keeper Light
старыми версиями SeaMonkey и FireFox

    Совсем недавно, числа 24 мая WebMoney "облагодетельствовала" нас новой версией интерфейса. Особенно были "обрадованы" пользователи WM Keeper Light, оставившие в ссылающемся топе кучу нелестных замечаний. Особенно неприятно что убрали поддержку младших версий браузеров - хотя, как я выяснил в процессе экспериментов, функционально новая версия кошелька WebMoney Keeper Light продолжает нормально в них работать. Что же делать? Ставить новые версии? Оказывается совсем необязательно.
    Оказалось что для того чтобы узнать, "может" ли работать с этой версией браузера WebMoney Keeper Light он тупо смотрит на User-Agent и в дальнейшем пускает или не пускает в кошелёк. А, следовательно, проблема решается простой подменой User-Agent браузера.
    Способы быстрой замены User-Agent без применения внешних программ существуют практически для всех браузеров - FireFox/SeaMonkey, Opera, Chrome. Но, поскольку я в основном работаю в FireFox и SeaMonkey - то приведу решение для них.

      1. Набираем в адресной строке about:config. Соглашаемся что будем работать осторожно.
      2. Заводим новый строковый параметр. Для этого щёлкаем правой кнопкой мыши на пустом месте и в открывшемся контекстном меню выбираем "Создать"->"Строка".
      2.1 В поле "Введите имя настройки" вводим general.useragent.override.
      2.2 В поле "Введите значение(строка)" вводим знамение User-Agent, с котором WebMoney Keeper Light нормально работает. Я ввёл Mozilla/5.0 (Windows NT 5.1; rv:10.0.4) Gecko/20100101 Firefox/10.0.4 - такой User-Agent выдаёт Firefox 10.0.4ECR. К слову, если параметр general.useragent.override уже присутствует в настройке, то в поле выдастся текущее его значение.
      3. Всё! Теперь WebMoney Keeper Light будет нормально работать в Вашем браузере. Сам браузер даже не надо перезапускать).

    UPD: Впрочем, если у Вас браузер, который не позволяет изменить User-Agent или Вы не хотите это делать - то можно войти по "старому входу": https://light.webmoney.ru/v2/default.aspx. Кое-какие глюки с ним есть - но работать можно.

    UPD2: В пользовании "старым входом" замечен один глюк - входящие транзакции(те, что показываются при нажатии на "крутящуюся монетку") показываются с некоторым запозданием. Но при этот величины, отображаемые в кошелях, правильные.
    P.S. Возможно это связано с тем, что я совместно использую версии 2 и 3. А может так специально задымано - чтобы переходили на новую версию)).

    UPD3: Заметил, что в половине случаев после завершения работы SeaMonkey значение параметра general.useragent.override теряется. Если не можете после перезапуска SeaMonkey войти в WebMoney Keeper Light, то проверьте, не пропал ли этот параметр. Если он пропал - введите его заново.

    UPD4: После небольшого периода "полного отказа обслуживания "старых" браузеров", который случился у WebMoney сразу после новогодних каникул они опять изменили свою политику - старые браузеры нормально стали работать с 3-й версией WebMoney Keeper Light без подмены ответа UA браузера с помощью переменной general.useragent.override. Однако по прежднему можно использовать(и весьма успешно, как проверено на практике) такой способ "подмены" и в других случаях "повышенных требований" различных сайтов или онлайн-сервисов.

    Статья обсуждается на Всеобщем форуме в этом топе.
    Копия статьи помещена в мой дневник.

Назад
© 1997-2017 2A Group(A.Chudnovsky, A.Serjogin)