ANNA
       Free Cat
       Кредо Группы 2А
  2A Представляет:
     Наши статьи
     Картины Анны
     Рассылки
     Проекты
     Книги
     Мы поддерживаем

   Написать письмо
   Послать Открытку
   Завалиться в Форум
   Потрепаться в ЧАТе
   Закрытая Гостевая
   На Главную
 

Как использовать в Mozilla FireFox(SeaMonkey) плагины, которые браузер называет "устаревшими"

    Очень часто бывает необходимо использовать плагин, который Mozilla FireFox(SeaMonkey) считает "устаревшим". По своим "причинам". Т.е. использовать он его даёт - но каждый раз перед использованием приходится его активизировать. Это очень неудобно. Можно ли избежать этого?
    Оказывается да ... причём достаточно простым способом.

    Всё, что надо сделать - это всего лишь немного исправить файл pluginreg.dat в профиле Mozilla FireFox(SeaMonkey).
    Нажимаем Пуск, затем Выполнить, вводим строку %APPDATA%\Mozilla\Firefox\Profiles\ ( %APPDATA%\Mozilla\Seamonkey\Profiles\ для Seamonkey) и нажимаем ОК. Затем переходим в каталог с расширением default.
    Если Вы пользуетесь программой FAR(или Total Commander) - то выполните команду cd %APPDATA%\Mozilla\Firefox\Profiles\ (cd %APPDATA%\Mozilla\Seamonkey\Profiles\ для Seamonkey) и аналогично перейдите в каталог с расширением default.

    Открываем файл pluginreg.dat любым текстовым редактором. В нём прописаны установленные плагины - а также вся информация по ним. Нам необходимо найти и исправить версию нужных плюгинов.
    Допустим нам надо изменить версию у Flash-плагина. Набираем в адресной строке about:plugins и получаем такую информацию:
about:plugins, информация до изменения
    У данного Flash-плагина в первых 2 параметрах описано имя файла, путь к нему. 3-й параметр - это версия плагина. Идем в файле pluginreg.dat по имени файла и видим аналогичные строки:
pluginreg.dat, искомая информация
    Теперь меняем в строке версии с 16.0.0.235 на 19.0.0.235 и перезапускаем браузер. Снова набираем в адресной строке about:plugins и видим уже такое:
about:plugins, информация после изменения
    Браузер теперь считает что версия плагина 19.0.0.235. Вуаля :) !
    Аналогичным образом можно править версии тех плагинов, которые Вы хотите использовать - но браузер считает их "устаревшими".

    Статья обсуждается на Всеобщем форуме в этом топе.
    Копия статьи помещена в мой дневник.

Назад
© 1997-2017 2A Group(A.Chudnovsky, A.Serjogin)